Thumbnails not showing

Bugs and issues.
Post Reply
Message
Author
fc_fzx
Posts: 5
Joined: 19.05.2022, 21:06

Thumbnails not showing

#1 Post by fc_fzx » 19.05.2022, 21:18

For a long while, Win File Manager did not display media thumbnails, which is why I started using FreeCommander, which was fantastic, offering options that file manager did not.
Then something weird happened. After a recent Windows upgrade, Win File Manager was able to show media thumbnails again, but now, FreeCommander did not! I get icons, but no thumbnail previews. I work with a large number of media files, and not being able to preview thumbnails at a glance is very inconvenient. I could just go back to using File Manager, but I've grown so used to all the cool features in FreeCommander.

I've looked for settings to change, bits to flip, re-installed, upgraded, re-installed again, re-booted ... there's nothing I have found that works. I have to believe there is some super easy little setting someplace.

Any suggestions are appreciated.

Currently, I'm working with this:
FreeCommander XE 2022 Build 861 32-bit public
Windows 10 Pro 64-bit 21H1 OS_Build 19043.1706
Windows Feature Experience Pack 120.2212.4170.0

thx

Marek
Author
Author
Posts: 3435
Joined: 10.04.2006, 09:48
Location: Germany
Contact:

Re: Thumbnails not showing

#2 Post by Marek » 19.05.2022, 21:37

Which file type is not shown as thumbnail?

fc_fzx
Posts: 5
Joined: 19.05.2022, 21:06

Re: Thumbnails not showing

#3 Post by fc_fzx » 19.05.2022, 22:38

All file types get a default generic thumbnail, where before, images and videos showed a content preview thumbnail.
It doesn't seem to discriminate.

User avatar
Dreamer
Site Admin
Posts: 5234
Joined: 19.08.2007, 23:40

Re: Thumbnails not showing

#4 Post by Dreamer » 19.05.2022, 23:11

I had the same problem, it's quite weird.

832 - Thumbnails are not loading - FreeCommander Forum
844 - No thumbnails in FC and Windows Explorer for png, jpg... - FreeCommander Forum

You can try to delete unimportant files, or/and just wait few days.

fc_fzx
Posts: 5
Joined: 19.05.2022, 21:06

Re: Thumbnails not showing

#5 Post by fc_fzx » 20.05.2022, 04:05

Before this problem started, about a week ago, I had a folder open with thumbnails shown.
Now, every time I restart FC, it resets to THAT day, showing those thumbnails. But if I navigate away and back again, it doesn't show them.
So, the last time it was working, it must have saved it's settings someplace, reloading on restart, but then, it must NOT be saving it's settings since then.

I'm considering a complete removal of FC and re-install. <ugh>
I'll let you know what happens.

fc_fzx
Posts: 5
Joined: 19.05.2022, 21:06

Re: Thumbnails not showing

#6 Post by fc_fzx » 20.05.2022, 19:42

OK reinstalled earlier version.
Still no thumbnails.
So, I'm guessing that FC is relying on something from the OS that's not being provided.
What would that be?

User avatar
Dreamer
Site Admin
Posts: 5234
Joined: 19.08.2007, 23:40

Re: Thumbnails not showing

#7 Post by Dreamer » 20.05.2022, 20:19

You can read my topics from the links above.

I had the thumbnails in one FC instance and no thumbnails in another FC instance, in the same time.

You can try to wait - as I wrote in that topic, 5-20 minutes, just to test it, leave the FC opened and do something else.

I think the system is re-building all thumbnails in all folders and the active folder is not first.

Make sure, you have enough disk space, try to delete the files you don't need.

If possible, you can try to leave the FC (and Windows Explorer) opened as long as possible, even hours.

fc_fzx
Posts: 5
Joined: 19.05.2022, 21:06

Re: Thumbnails not showing

#8 Post by fc_fzx » 21.05.2022, 00:45

Respectfully ...
I have FC open all the time. The next day, no thumbnails. If it were building in the background, I think I'd see some little CPU or Disk usage spike for that process.
Why would it even do that? If I moved a file would I have to wait 20 minutes to see it?
I'm not the person who wrote the code, but I wouldn't write code like that.

User avatar
Dreamer
Site Admin
Posts: 5234
Joined: 19.08.2007, 23:40

Re: Thumbnails not showing

#9 Post by Dreamer » 21.05.2022, 14:08

First, I'm not the author of the FreeCommander, I'm just a moderator. What I wrote was my experience, it's a very strange issue and I'm not sure if it's a Windows or FreeCommander issue, I don't think any other user had this issue, just me, few times, also in 2020 and 2021, both times it was fixed itself after 3 days.

You can try this tip from Marek too, but it will clear thumb cache, so if you have lot of images on disk, all thumbnails must be created again - and as I said, I think that active folder files don't have to be created first, so again, be patient, please, I know it's annoying, but it should be fixed in few days.
Marek wrote: 06.03.2021, 17:07I have not tried but may be help to clear Windows thumb cache: https://neosmart.net/wiki/clear-thumbna ... _Windows10
Here is the proof, how weird these issues are:
Dreamer wrote: 09.03.2021, 00:19 I can reproduce it with default settings:
- ended all fc.exe processes in task manager
- removed all files from SettingsTest folder
- started fc with default settings, these parameters:

Code: Select all

/N /NewIni=%FcSrcDrive%\Programs\!Misc\Settings\FreeCommander\SettingsTest\FreeCommander.ini /NoPlugins /ShowHidden /Lng=English /size=800x600
- tab1 - changed path to folder with png icons 64px
- tab2 - opened new tab d: - list view
- tab1 - changed view to thumbs
- switch to tab2, tab1 first time
- thumbs are ok
- switch to tab2, tab1 second time
- thumbs are ok
- switch to tab2, tab1 third time
= thumbs are broken

FC 8443+
And after this it was fixed itself the next day, same FC version, same settings, no OS update, no other changes.

Finally, since I had the same bug few times already, in older versions and I don't have it now, I think it's not a bug for the specific FC version or setting, but some strange system bug.

FCunlimited
Posts: 1
Joined: 15.06.2022, 09:36

Re: Thumbnails not showing

#10 Post by FCunlimited » 15.06.2022, 09:46

Hi,

I have the same problem and maybe some of this helps you to find a solution:
- I think it started when I updated to windows 11 but not sure
- I use FreeCommander XE 2022 Build 869 64-bit (had the same problem with the old versions)

Now the best: Is it possible that FC starts loading the thumbnails and somehow at some point this background thread gets disconnected from the main thread?
So the event for updated GUI is not fired.
Because: If I open a folder it starts to load the first thumbnails and then stops but if I switch to another tab and back more thumbnails will be shown.

horst.epp
Posts: 309
Joined: 15.11.2008, 20:18

Re: Thumbnails not showing

#11 Post by horst.epp » 15.06.2022, 18:29

Here under Windows 11 FC has no such problems with Thumbnails.
Thumbnails are provided from the OS by the installation of the K-Lite Codec Pack.
This contains the Icaros Thumbnail provider.
Windows 11 Home x64 Version 21H2 (OS Build 22000.778)
Everything Version 1.5.0.1315a (x64)
FreeCommander XE 2022 Build 872 64-bit donor

Forez
Posts: 627
Joined: 30.01.2016, 12:05
Location: In front of a PC monitor

Re: Thumbnails not showing

#12 Post by Forez » 16.06.2022, 14:30

fc_fzx wrote: 20.05.2022, 19:42 OK reinstalled earlier version.
Still no thumbnails.
So, I'm guessing that FC is relying on something from the OS that's not being provided.
What would that be?
Although I am using Windows 10, this sounds similar to my problem, as is also concerns Thumbnails: viewtopic.php?p=38932

Is your issue manifesting itself only for Thumbnails, or also for icons when using List or Details mode of viewing?

Post Reply

Who is online

Users browsing this forum: Baidu [Spider] and 4 guests