"Fit" images in thumbnail view

Discussion and questions - donor version.
Post Reply
Message
Author
hanjo
Posts: 7
Joined: 03.05.2020, 01:16

"Fit" images in thumbnail view

#1 Post by hanjo » 16.05.2022, 11:46

Hi,

I noticed that in the Thumbnail FAQ the images in the thumbnail are in "fit" mode, meaning the entire image can be shown. However, for me (Build 869), the thumbnails are in "fill" mode or something similar, meaning I only get to see a cropped part of the image.

Here is a visualization:

Freecommander:
Image

Explorer:
Image

I checked the settings dialogue, but could not find an option to change this behavior. Any Idea how to change Freecommander to "Fit" mode, so the entire image can be seen in the thumbnail?

Thanks

User avatar
Dreamer
Site Admin
Posts: 5397
Joined: 19.08.2007, 23:40

Re: "Fit" images in thumbnail view

#2 Post by Dreamer » 16.05.2022, 20:56

Which OS?

I can't confirm it in 869 64-bit, Windows 10 21H1 64-bit.

hanjo
Posts: 7
Joined: 03.05.2020, 01:16

Re: "Fit" images in thumbnail view

#3 Post by hanjo » 17.05.2022, 09:11

I'm running FreeCommander XE 2022 Build 869 64-bit on Windows 11 64-Bit Version 21H1 (OS Build 22000.675).

hanjo
Posts: 7
Joined: 03.05.2020, 01:16

Re: "Fit" images in thumbnail view

#4 Post by hanjo » 06.09.2022, 11:23

Hi,

in the meantime I upgrade to FreeCommander XE 2022 Build 873 64-bit and Windows got updated to Build 22000.856, however the rendering of the thumbnails is still in a fill-like mode, as shown above.

Any idea what could be causing this?

Thanks
Greetings
Hanjo

hanjo
Posts: 7
Joined: 03.05.2020, 01:16

Re: "Fit" images in thumbnail view

#5 Post by hanjo » 01.10.2022, 15:52

Hi,

I was able to tracke the issue down: The thumbnails are shown correctly (i.e. "fit") for files that are locally stored in some folder. However, for files that are stored in the cloud, e.g. OneDrive, Dropbox or - in my case - Synology Drive, the thumbnails are shown incorrectly (i.e. "fill"). I assume this is due to the fact that thumbnail creation in this case is done by querying the server (through the cloud client) for the thumbnail, instead of download the entire file and creating the thumbnail locally.

The weird thing is that in Windows Explorer the result is what you would expect, where in FreeCommander somehow the thumbnails are enlarged and cropped, like shown in the image in my first post.

Any chance this could be fixed?

Thanks
Greetings
Hanjo

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests