ColorSchemas are not removed after restoration of settings

Bugs and issues.
Post Reply
Message
Author
Forez
Posts: 399
Joined: 30.01.2016, 11:05
Location: In front of a PC monitor

ColorSchemas are not removed after restoration of settings

#1 Post by Forez » 13.07.2019, 19:05

If you ma make a backup of your settings, then those files will include Color Schemas files

If later on you will restore them- .COLOR file will be merely added to the existing ones in the

C:\Users\USER-NAME\AppData\Local\FreeCommanderXE\Settings\ColorSchemas

folder


And that is plain wrong. If we restore setting we want to have some old tabs right? And not current tabs plus old tabs. So the same should be true for Color Schemas



I was using FreeCommander XE 2018 Build 770 32-bit public on Windows 7 x64 at that time

User avatar
Dreamer
Site Admin
Posts: 3545
Joined: 19.08.2007, 21:40
Location: Slovakia

Re: ColorSchemas are not removed after restoration of settings

#2 Post by Dreamer » 13.07.2019, 19:35

I can't confirm this in build 800 donor. Are you using any color scheme before you backup the settings? If not, perhaps the option is missing and it's a bug, but if you use any scheme first, even default white, then it should be OK.

I found another bug, I'll create a new topic.

Forez
Posts: 399
Joined: 30.01.2016, 11:05
Location: In front of a PC monitor

Re: ColorSchemas are not removed after restoration of settings

#3 Post by Forez » 30.10.2019, 12:41

Dreamer wrote:
13.07.2019, 19:35
I can't confirm this in build 800 donor. Are you using any color scheme before you backup the settings? If not, perhaps the option is missing and it's a bug, but if you use any scheme first, even default white, then it should be OK.

I found another bug, I'll create a new topic.
This happens also in FreeCommander XE 2018 Build 770 32-bit public

And yes, I am using a color scheme, of mine own. A new / updated version of it now and an older one when I restore older settings. [And then I restore my current settings and wham!- I suddenly have XX in between versions of my Color Scheme on the list]


But I did a test:
1] I switched to White_Default
2] Saved settings
3] Exported settings
4] Restored settings from April of 2016
5] Switched from an early version of my Colore Scheme to White_Default
6] Saved settings
7] Exported settings [in theory this step was of no importance]
8] Restored settings from point 3

Result: the old Color Schemas did not get delete - as usueal they were retained in the
C:\Users\YOUR-USER-NAME\AppData\Local\FreeCommanderXE\Settings\ColorSchemas
folder thus added to my current ones


[Please paste here link to that new bug if it is relevant to this issue]

User avatar
Dreamer
Site Admin
Posts: 3545
Joined: 19.08.2007, 21:40
Location: Slovakia

Re: ColorSchemas are not removed after restoration of settings

#4 Post by Dreamer » 31.10.2019, 20:05

Try the latest version, 804 public beta or donor, it's beta, but it's really stable and safe to use, with many bugs fixed.

Forez
Posts: 399
Joined: 30.01.2016, 11:05
Location: In front of a PC monitor

Re: ColorSchemas are not removed after restoration of settings

#5 Post by Forez » 10.11.2019, 18:20

Dreamer wrote:
31.10.2019, 20:05
[...]
804 public beta
[...]
It seems that now I have the opposite problem- when loading Settings nothing is added from them from the

C:\Users\YOUR-USER-NAME\AppData\Local\FreeCommanderXE\Settings\ColorSchemes


folder to the list of Schemes within FC. And yes, I had Windows Explorer opened the whole time to see if something was changing- and yes, I was even refreshing it to be sure

User avatar
Dreamer
Site Admin
Posts: 3545
Joined: 19.08.2007, 21:40
Location: Slovakia

Re: ColorSchemas are not removed after restoration of settings

#6 Post by Dreamer » 10.11.2019, 18:34

I'm not sure, but perhaps you need to restart FC for this.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests