Possible to hide links

Discussion and questions - donor version.
Post Reply
Message
Author
quocvuong154
Posts: 1
Joined: 19.09.2019, 06:55

Possible to hide links

#1 Post by quocvuong154 » 19.09.2019, 07:00

Hi all,

Is it possible to hide links in the desktop view so that I can only see the files and folders on the desktop?

Thanks

cogollito al reverso
Posts: 7
Joined: 29.06.2018, 23:19

Re: Possible to hide links

#2 Post by cogollito al reverso » 13.11.2019, 04:53

Hi, I know of two ways to do that, A or B, but only A will do it on the desktop of the OS (outside of FC GUI):

A. Open the Desktop folder in FreeCommander. Sort by file type. Select all *.lnk files (shortcuts). Hit Shift+Enter or Go to the File menu of FC (Alt+F) and select Attributes/Timestamp. There you can set the Hidden attribute for all the files you selected.

B. i) This may not be a solution you like, but this will 'work' too -in the sense of making your Desktop shortcuts INVISIBLE or barely visible, as you prefer, which of course is not quite the same as the above hide/unhide because they will still always take up a line in a file list even if the line appears empty:

1. Rename all desktop links: For example, replace ".lnk" with "_(desk).lnk". So, FreeCommander.lnk would be renamed FreeCommander_(desk).lnk within the Desktop folder.

2. Go to Settings > File/folder list > Items color > Color by file type

3. Create a new filter for "*_(desk).lnk" -or whatever tag you prefer- and give it a color that is identical or nearly identical to your background color, such that the font color for link files on the desktop will be as near to invisible as you like.

B. ii) OR, you could use Color by attributes & the modified timestamp as your defining characteristic, if you set all desktop shortcuts with a particular (AND unique, systemwide) Modified Date.

[EDIT] Please note the changes below, and also that my FC settings files are likely corrupt. So, when I implement method B., above, I get the new color for renamed *[desk].lnk files AND I also get it for SOME of my other link files that haven't even one character in common with "[desk]". The brackets may be operating as a kind of regex, because I got it back to working only on the desired links by using *desk*.lnk, without brackets.

Regarding method B.:
-First, in the Color by File Type rules list, maybe avoid using brackets and *desk*.lnk should work for link files whose names end with "_[desk].lnk".
-Second, in that same list, after you create your rule for this custom-named .lnk file, it must be moved up the rule list so that it is above the general *.lnk rule.

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests