657-Address Bar has no text

Bugs and other issues or requests which have been resolved.
Post Reply
Message
Author
Zorkoff
Posts: 113
Joined: 10.05.2011, 23:14
Location: Boston, MA

657-Address Bar has no text

#1 Post by Zorkoff » 07.04.2014, 19:18

I started using FCXE-657 (x86 and x64) today and noticed that the Address Bar has no text. Also, left clicking the Address Bar does not shift focus to the other panel and it does not display the file history.

This screenshot shows the detail.

Image

Also, the screen shot of my bug report of missing toolbar icons in FCXEx64-656, shows that it did not display text in the address bar either. (viewtopic.php?f=9&t=5868#p18427)

All the toolbar icons are working normally again. Thanks for the fast release of 657.

Bill
Posts: 15
Joined: 16.10.2007, 15:20
Location: Toronto, Canada

Re: 657-Address Bar has no text

#2 Post by Bill » 07.04.2014, 19:32

I can confirm that in release 657, the main window title is blank for both panels. I tried [folder], [drive] [folder] and [path]. All are blank. Windows XP, Classic theme.

Thank you.

joby_toss
Posts: 1345
Joined: 22.07.2009, 21:19
Location: Romania
Contact:

Re: 657-Address Bar has no text

#3 Post by joby_toss » 07.04.2014, 20:48

Works fine for me (x86 and x64 portable with default settings and x64 portable heavily customized) on my win7x64sp1.

Image

bertradio
Posts: 18
Joined: 10.01.2014, 15:09

Re: 657-Address Bar has no text

#4 Post by bertradio » 07.04.2014, 21:11

Blank for me as well with 657 x64.

joby_toss
Posts: 1345
Joined: 22.07.2009, 21:19
Location: Romania
Contact:

Re: 657-Address Bar has no text

#5 Post by joby_toss » 07.04.2014, 21:31

So you can replicate the problem with default settings? Just download a portable package and start the app.
If not, you should send your .ini file to Marek so he can identify the conflicting setting.

bertradio
Posts: 18
Joined: 10.01.2014, 15:09

Re: 657-Address Bar has no text

#6 Post by bertradio » 07.04.2014, 22:31

I downloaded x64 and ran it from a new folder. With the default ini I saw the paths. I then copied my ini into the new SETTINGS folder and opened FC -- no paths. So the problem is definitely some kind of conflict in my ini (which worked fine with prior versions). I can email my ini if someone will send me an email address.

Zorkoff
Posts: 113
Joined: 10.05.2011, 23:14
Location: Boston, MA

Re: 657-Address Bar has no text

#7 Post by Zorkoff » 07.04.2014, 22:49

I have narrowed down the problem for the Address Bar missing text.

At the time the program is started, if the FreeCommander.ini file has the entry

ShowDriveBtnInAddressBar=1

The address bar displays text normally. However if the value is "0" there is no text and left clicking will not show the address history or switch to that panel.

This is controlled by: Settings > View > Drives > Show drive button in address bar

This worked correctly in Release 654 but failed in 656 and 657

Changing the value through Settings while the program is running will give the expected changes, it is on program start that the error appears.
Last edited by Zorkoff on 07.04.2014, 23:07, edited 1 time in total.

joby_toss
Posts: 1345
Joined: 22.07.2009, 21:19
Location: Romania
Contact:

Re: 657-Address Bar has no text

#8 Post by joby_toss » 07.04.2014, 23:03

You found it! Nice job!

If this option is disabled, the bug is present:

Image

joby_toss
Posts: 1345
Joined: 22.07.2009, 21:19
Location: Romania
Contact:

Re: 657-Address Bar has no text

#9 Post by joby_toss » 10.04.2014, 15:44

Fixed in 658. Thanks!

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests