Drag operation failed (GetDataObjectFromIndexList): The parameter is incorrect [& other errors]

Bugs and issues - current donor version.
Post Reply
cogollito al reverso
Posts: 6
Joined: 29.06.2018, 23:19

Drag operation failed (GetDataObjectFromIndexList): The parameter is incorrect [& other errors]

#1 Post by cogollito al reverso » 10.11.2019, 20:56

Apologies, I don't see a better subforum for my issues. This is not a bug report, but a request for help troubleshooting without loosing my settings, but I doubt my settings are very extensive or complex compared to others on the forum. (I'd like to avoid re-creating favorites & color settings by both file/folder date and by file type. I do have extensive backups, though, of many portable FC versions). My fear is that I have corrupted some settings files and that it won't be possilbe to determine which backup files are free of corruption.

Portable FreeCommander XE 2019 Build 806 64-bit donor, Windows 10 64-bit 15063.rs2 1703
- I went from from FC v.798 to v800 to v806, and the problems began during v.800.
- i have no plug-ins, unless we count Everything.exe with the accompanying script [* see below *].
- The errors do NOT occur via FC v.806 [FreeCommanderXE-64-donor_portable_806.zip] when unzipped and launched as a virgin copy. I tried that because my system rejects your command line [/N /NewIni=%FcSrcPath%\TestSettings\FreeCommander.ini /NoPlugins /Lng=English] - "/N" unrecognized, which I tried in admin cmd prompt, via PowerRun_x64, and the FC Dos Box.

Below are my 3 RECURRING ERRORS.

1. Error & can't drag files sometimes; error comes as soon as i start to move after a left click-and-hold with mouse.
==> error is: FreeCommander - Drag operation failed (GetDataObjectFromIndexList): The parameter is incorrect
- i CAN sometimes perform this in FC error-free AFTER manually applying sorting to the directory in which the error occurred.
- can't drag and drop a file from 7-zip (7z file manager) into a folder open in FC
- [i don't use explorer, but i CAN do this all within Everything search results GUI, just not within FC]

2. Error & can't copy a folder btwn directories/panes unless the folder has a file inside it; empties won't produce an error but nothing ends up in the destination.
==>error is: FreeCommander - Operation failed : %PATH%\FileName.Ext

3. Error & can't create new folder sometimes, or rename an existing one.
==>Error is: FreeCommander - Operation failed : %PATH%\FileName.Ext
- error persists across manual sort of directory, unlike in the error when dragging

Proabably unrelated problems:
- (every folder opens unsorted and requires, for example, clicking the Name column header Twice for increasing alphabetic sort.)
- (as i pass the cursor over items in the file list panes, active or inactive, the item names change font color, a color that is hard to read over the the background color which does not change. I can find no setting to correct this, and I can find no color setting where I have used this font color.)

Thank you to anyone who can help!

* fyi *
The Everything script is acutally kept in the Everything app folder, so not really installed in FC. It looks like this:

Code: Select all

@echo off
Setlocal EnableDelayedExpansion
set filenames=
for /f "usebackq tokens=*" %%A in ("%1") do (
  set filenames=!filenames! "%%A"
rem echo %filenames%
"Everything.exe" -rename %filenames%

Posts: 2656
Joined: 10.04.2006, 07:48
Location: Germany

Re: Drag operation failed (GetDataObjectFromIndexList): The parameter is incorrect [& other errors]

#2 Post by Marek » 10.11.2019, 21:46

Send me your settings that do not work and I can try to check it.

cogollito al reverso
Posts: 6
Joined: 29.06.2018, 23:19

Re: Drag operation failed (GetDataObjectFromIndexList): The parameter is incorrect [& other errors]

#3 Post by cogollito al reverso » 11.11.2019, 11:44

Thanks for your reply.

Current Resolution:
I've sent you 2 emails with "back up all settings" 7zips, one from the corrupted v.806 settings, and then a new one of settings restored into v.806 from an old v.783, which seems to have fixed the 3 recurring errors.
--> Let me know if you don't receive the emails (or maybe you no longer need to see those files).
--> Are there known incompatibilities with v.806 when importing such old settings files?

Summary of What MAY have led to the errors:
1. A very stupid attempt I had made to perform a code search/replace within all of the settings files. That was months ago.
2. I also remembered that more recently I wanted to clean up all the theoretically unused Layouts and Color Schemes. So, I deleted all the ones I thought I wasn't using.
--> ..but I think there must be dependencies among older and newer Layouts and Color schemes...is that possible?

For now, things seem to be running smoothly! Even the aforementioned "Probably unrelated errors" are resolved.

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests