804 - Viewer in search dialog doesn't highlight "containing text" consistently

Bugs and issues - current donor version.
Post Reply
Message
Author
Odamn-Ete
Posts: 77
Joined: 28.06.2017, 05:10

804 - Viewer in search dialog doesn't highlight "containing text" consistently

#1 Post by Odamn-Ete » 28.10.2019, 04:32

In performing tests regarding this issue viewtopic.php?f=7&t=9909

I have noticed that when viewing files in the search results panel, the viewer opens, displays the file with the search term "containing text" highlighted inconsistently.

The first two files are displayed properly, i.e. "containing text" is highlighted.
The next two files are displayed but the "containing text" is only partially highlighted.
The following two files are displayed but the "containing text" is not highlighted, instead, the last letter of the line above the "containing text" is highlighted.
The following two files are displayed but the "containing text" is not highlighted, instead, three letters of the last six letters of the line above the "containing text" are highlighted.

additional information:
The term "containing text" contained only three letters.
The term "containing text" was at the beginning of the line.
When using a term for "containing text" consisting of two words, a similar behavior was observed.
Some of the files listed further down in the search results panel displayed the "containing text" properly, but not all.
Test was performed with my normal configuration as well as with the default configuration.

FreeCommander XE 2019 Build 804 64-bit donor
Windows 10 Pro 64-bit Version 1903 Build 18362.449


Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests