hidden folder is visible

Bugs and issues - current donor version.
Post Reply
Message
Author
reiver
Posts: 7
Joined: 06.03.2014, 19:41
Location: Scotland

hidden folder is visible

#1 Post by reiver » 10.02.2017, 11:35

MS Office's OneDrive creates a folder called OneDriveTemp in the root directory of the drive where your OneDrive folder is located. You can delete it but it reappears whenever One Drive starts.

The folder's attribute is 'Hidden' I have FC (XE 2017 Build 740 64-bit donor) set to not show system or hidden files and yet it is always visible in the left hand pane but, curiously, not the right hand one. It is not visible at all in Explorer.

If I set FC to show hidden files/folders then it does appear in the right hand pane.

I don't know if I'm doing something wrong or whether this might be a bug. In any event, I really do not want to see that folder at all so I wonder if it's possible to really make it hidden?

User avatar
ralfso
Posts: 697
Joined: 31.10.2007, 17:21
Location: Gifhorn, Germany

Re: hidden folder is visible

#2 Post by ralfso » 10.02.2017, 12:06

FreeCommander has two possible view settings for hidden/system-files/folders:

one for the tree: settings > tree > management: show hidden folders
one for the file/folder list: settings > file/folder list > general: show hidden files (&folders) & show system files (&folders)

viewtopic.php?f=19&t=7774#p25071
Regards
Ralf

Win10 (64-bit), Intel i7-2600 (3,4 GHz), 8 GB Ram, 2x2000 GB HD, NVIDIA GeForce 545

reiver
Posts: 7
Joined: 06.03.2014, 19:41
Location: Scotland

Re: hidden folder is visible

#3 Post by reiver » 10.02.2017, 14:18

Brilliant - many thanks - woo hoo!

The thread you pointed to hadn't come up in the searches I'd tried so my apologies for going over old ground. Like that contributor, though, as well as hiding the specific folder that I mentioned, I'd also like to see the hidden folder
C:\Users\<username>\AppData
and its subfolders as I use them quite a lot.

The solution came to me in one of those 'lightbulb moments'. If it helps someone else, then simply unhide the AppData folder. You just have to run a command prompt as Admin and use
attrib -h C:\Users\<username>\AppData

It's always a relief to find a solution to really irritating issues, so my day is now complete :)

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 4 guests