818 - Sometimes action bar icon does not display for a favorite tool

Bugs and issues - current donor version.
Post Reply
Message
Author
Free4all
Posts: 312
Joined: 30.09.2014, 19:12

818 - Sometimes action bar icon does not display for a favorite tool

#1 Post by Free4all » 25.04.2020, 18:55

818 Donor 64-bit

Because I have troubles using FC with USB-connected devices, I have one of my Favorite Tools set to be Windows Explorer.

In turn, I have that Favorite Tool as one of the items on my Action Bar.

Sometimes (but not always), when FC loads, the icon for that Action Bar item is blank. The button is technically still there, but the icon is completely blank.

It's probably some sort of timing or race issue that occurs when FC starts, because it only happens about 10-20% of the time.

The issue isn't new to v818, but it still occurs with it.

User avatar
Dreamer
Site Admin
Posts: 3901
Joined: 19.08.2007, 21:40

Re: 818 - Sometimes action bar icon does not display for a favorite tool

#2 Post by Dreamer » 25.04.2020, 19:41

Strange, I never had a blank icon in favorites tools bar (except a bug in some old versions).
Some icons are loaded later here, takes few seconds.

Which path are you using? Explorer.exe, or C:\Windows\explorer.exe?
How many favorite tools items are you using?
Do you have a HDD or SSD for OS/FC? If HDD, which one?

Try to set the path for icon manually, create a duplicate button with the custom path for icon - and perhaps another item, with the custom own icon (non-Windows).

FC 818 donor 64-bit, Windows 10 64-bit 1909.
Free4all wrote:
25.04.2020, 18:55
Because I have troubles using FC with USB-connected devices, I have one of my Favorite Tools set to be Windows Explorer.
Which issue is it? Reported already? Link?

Free4all
Posts: 312
Joined: 30.09.2014, 19:12

Re: 818 - Sometimes action bar icon does not display for a favorite tool

#3 Post by Free4all » 26.04.2020, 07:29

Dreamer wrote:
25.04.2020, 19:41
Strange, I never had a blank icon in favorites tools bar (except a bug in some old versions).
Some icons are loaded later here, takes few seconds.
Yes. I'm rather patient. I wait about 15 seconds. If it hasn't appeared, I close FC and restart it.
Dreamer wrote:
25.04.2020, 19:41
Which path are you using? Explorer.exe, or C:\Windows\explorer.exe?
C:\Windows\explorer.exe
Dreamer wrote:
25.04.2020, 19:41
How many favorite tools items are you using?
In Customize Favorite Tools, I have 7 favorites listed, and 2 separators.
Dreamer wrote:
25.04.2020, 19:41
Do you have a HDD or SSD for OS/FC? If HDD, which one?
HDD 5400RPM
Dreamer wrote:
25.04.2020, 19:41
Try to set the path for icon manually, create a duplicate button with the custom path for icon - and perhaps another item, with the custom own icon (non-Windows).
OK. I will experiment with that.
Free4all wrote:
25.04.2020, 18:55
Because I have troubles using FC with USB-connected devices, I have one of my Favorite Tools set to be Windows Explorer.
Dreamer wrote:
25.04.2020, 19:41
Which issue is it? Reported already? Link?
There are many reported issues regarding this problem. Here are some of the related ones, in reverse-chronological order (newest first, oldest last):

viewtopic.php?f=6&t=10411
viewtopic.php?f=19&t=8911
viewtopic.php?f=18&t=8910
viewtopic.php?f=7&t=8557
viewtopic.php?f=19&t=8039
viewtopic.php?f=19&t=7226
viewtopic.php?f=7&t=7170
viewtopic.php?f=18&t=6703

The forum software only allows posting 8 URLs, so I'm modifying the next one a little to allow it to go through.

zhttps://freecommander.com/forum/viewtopic.php?f=7&t=6580

User avatar
Dreamer
Site Admin
Posts: 3901
Joined: 19.08.2007, 21:40

Re: 818 - Sometimes action bar icon does not display for a favorite tool

#4 Post by Dreamer » 26.04.2020, 13:25

Some icons are loading longer than others, even few seconds, perhaps FC is loading something else too, or your HDD may be fragmented (you can check it), so try to wait at least few minutes, especially on first start after PC (re)start.

Free4all
Posts: 312
Joined: 30.09.2014, 19:12

Re: 818 - Sometimes action bar icon does not display for a favorite tool

#5 Post by Free4all » 26.04.2020, 19:28

Dreamer wrote:
26.04.2020, 13:25
Some icons are loading longer than others, even few seconds, perhaps FC is loading something else too, or your HDD may be fragmented (you can check it), so try to wait at least few minutes, especially on first start after PC (re)start.
I'll give it 5 minutes. HDD defragmented regularly.

Free4all
Posts: 312
Joined: 30.09.2014, 19:12

Re: 818 - Sometimes action bar icon does not display for a favorite tool

#6 Post by Free4all » 26.04.2020, 20:44

Dreamer wrote:
26.04.2020, 13:25
Some icons are loading longer than others, even few seconds, perhaps FC is loading something else too, or your HDD may be fragmented (you can check it), so try to wait at least few minutes, especially on first start after PC (re)start.
Well, I just gave it an hour and 15 minutes. No icon.

User avatar
Dreamer
Site Admin
Posts: 3901
Joined: 19.08.2007, 21:40

Re: 818 - Sometimes action bar icon does not display for a favorite tool

#7 Post by Dreamer » 27.04.2020, 15:20

I created "C:\Windows\explorer.exe" item and the icon is loading correctly until now.

Perhaps the problem is, that system is "busy", if your FC is starting with windows, try to wait 5 minutes before you start FC first time.

Anyway, I think I can't help you more, perhaps you could send the freecommander.ini file to Marek.

Free4all
Posts: 312
Joined: 30.09.2014, 19:12

Re: 818 - Sometimes action bar icon does not display for a favorite tool

#8 Post by Free4all » 28.04.2020, 05:36

Dreamer wrote:
27.04.2020, 15:20
I created "C:\Windows\explorer.exe" item and the icon is loading correctly until now.

Perhaps the problem is, that system is "busy", if your FC is starting with windows, try to wait 5 minutes before you start FC first time.

...
Thanks for your help. I'm not starting FC with Windows, and it will happen during the middle of computing sessions.

I'm guessing it's a timing or race condition, or a momentary file access error. I am skilled with a bunch of debugging tools, and if I have time, I might spend some time looking to see exactly what's happening. It's a little more challenging without the source code, but I know assembly language, so I can take a look at things at a low level.

Marek
Author
Author
Posts: 2761
Joined: 10.04.2006, 07:48
Location: Germany
Contact:

Re: 818 - Sometimes action bar icon does not display for a favorite tool

#9 Post by Marek » 28.04.2020, 20:58

Sometimes (but not always), when FC loads, the icon for that Action Bar item is blank. The button is technically still there, but the icon is completely blank.
Have you tried to define other icon for the button, simply ico file?

Free4all
Posts: 312
Joined: 30.09.2014, 19:12

Re: 818 - Sometimes action bar icon does not display for a favorite tool

#10 Post by Free4all » 03.05.2020, 00:43

Marek wrote:
28.04.2020, 20:58
Sometimes (but not always), when FC loads, the icon for that Action Bar item is blank. The button is technically still there, but the icon is completely blank.
Have you tried to define other icon for the button, simply ico file?
Hi Marek,

I haven't tried that yet. I assume that will work because I have other items defined that way, and they have no issues. Before doing that, though, I want to run a couple debuggers to see if I can tell why it's currently failing. I'm wondering if there is a file lock or something. When you read the icon from an executable, you are just opening the executable for read access, correct?

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests