Please? How Turn Off Column Auto-Sizing?

Discussion and questions - donor version.
Post Reply
Message
Author
kenh999
Posts: 3
Joined: 09.10.2013, 09:42

Please? How Turn Off Column Auto-Sizing?

#1 Post by kenh999 » 09.10.2013, 09:57

Hi,

I am a long-time devoted FC user. I use it multiple times a day. I've been using the beta for a while but didn't update for a while until I installed the latest version (0.621) on my new laptop last week.

What's with the auto-column resizing? I can not find how to turn that annoying feature off?

Is there a simple way to turn it off?

Thanks for any help.

Ken

Timon
Posts: 695
Joined: 13.09.2012, 06:51

Re: Please? How Turn Off Column Auto-Sizing?

#2 Post by Timon » 09.10.2013, 12:22

Tools - Settings - View - File/Folder list
0 - Max. column width for list view (0-auto size ...)
set value you need

kenh999
Posts: 3
Joined: 09.10.2013, 09:42

Re: Please? How Turn Off Column Auto-Sizing?

#3 Post by kenh999 » 09.10.2013, 13:13

Timon wrote:Tools - Settings - View - File/Folder list
0 - Max. column width for list view (0-auto size ...)
set value you need
I should have said in my OP: I tried that. I use detail view exclusively, not list view, and those settings only work for the list view.

how do I turn off column autosizing for the Detail view?

Timon
Posts: 695
Joined: 13.09.2012, 06:51

Re: Please? How Turn Off Column Auto-Sizing?

#4 Post by Timon » 09.10.2013, 14:22

I see the problem in details view.
That problem is present even in donor FC XE 634. In details view "Name" column width is aligned by the longest file name. Other columns sometimes go beyond the limits of the active panel.
This should be fixed in next version.

Karol
Posts: 756
Joined: 19.08.2007, 10:05

Re: Please? How Turn Off Column Auto-Sizing?

#5 Post by Karol » 09.10.2013, 15:06

Go to "Settings:Column profiles" and edit your profile (default profile if you have nothing changed): deactivate "Autosize for 'Name' column".

kenh999
Posts: 3
Joined: 09.10.2013, 09:42

Re: Please? How Turn Off Column Auto-Sizing?

#6 Post by kenh999 » 09.10.2013, 17:27

Karol wrote:Go to "Settings:Column profiles" and edit your profile (default profile if you have nothing changed): deactivate "Autosize for 'Name' column".
Thank You Karol!! :D That did it.

Timon
Posts: 695
Joined: 13.09.2012, 06:51

Re: Please? How Turn Off Column Auto-Sizing?

#7 Post by Timon » 09.10.2013, 17:28

Go to "Settings:Column profiles" and edit your profile (default profile if you have nothing changed): deactivate "Autosize for 'Name' column".
It doesn't work in my configuration (besides deactivation "Autosize for 'Name' column, you also need to define concrete column width other than 0).

jcaiken
Posts: 11
Joined: 10.01.2008, 23:38

Re: Please? How Turn Off Column Auto-Sizing?

#8 Post by jcaiken » 02.01.2014, 23:10

I have been cursing XE 650 for this reason. With the column widths in default, if I change the column with in Detailed view (by dragging the column boundary to a reasonable width) and then double-click on a Word file (to load it into Word) the column width gets reset to automatic when I close Word and return to FreeCommander XE.

This automatic column-width issue has been a long-running thread during the beta testing of XE - the automatic width for the Name column in the Detail view has been consistently based on the file name length, irrespective of the screen width and dual-pane view. There appears to have been a reluctance to change this default, with the responses to the issues raised consistently advising the user how to change the settings from the default. Could no one see that such a default is likely to create issues, particularly in the dual-pane view (which is a significant feature of FreeCommander)?

Could I suggest that the default maximum 'automatic' width for the Name column in the "fc_default_view" setting be set to 35 (or no more than 60% of the available window width in single-pane view), and provide the users with the option to make it full width (or set width to 0)?
Could I also suggest that in dual-pane view the "Type" column should be replaced with "Ext" and the "Include Ext in Name" option disabled?

assembler
Posts: 1
Joined: 24.06.2014, 09:13

Re: Please? How Turn Off Column Auto-Sizing?

#9 Post by assembler » 24.06.2014, 09:20

I've just started to use FreeCommander and encountered exactly the same problem with auto-resizing columns. After few tries I've found out that when I uncheck auto resize of name column in "fc_default_view" profile, save settings and resize name column by mouse, then return back to settings - auto resize is checked again. No matter what I've tried that settings always checks 'itself' and of course resizes name column.

But I also found a solution :-)! Just create new profile for columns, uncheck auto resize there and setup columns you want, then delete "fc_default_view" profile and everything works.

Rob Down Under
Posts: 2
Joined: 30.09.2014, 03:33

Re: Please? How Turn Off Column Auto-Sizing?

#10 Post by Rob Down Under » 30.09.2014, 03:42

Constantly changing column widths is about the most annoying thing in the universe.
Please provide an easy way to turn that horrible annoying feature off.
(I use details view in a single pane)

I have read the suggestions above, but I am unsure how to carry out those instructions EG -
- How to create profile
- How to use that profile
- How to add the desired entry, to turn off autosizing
Could someone provide easy instructions, for the uninitiated, thanks.

If I were sent to Mars, and only had a choice between two file mangers -
- Windows Explorer
- FreeCommander with annoying column autosizing

I would choose Windows Explorer.
And I have always thought Windows Explorer was horrible

Karol
Posts: 756
Joined: 19.08.2007, 10:05

Re: Please? How Turn Off Column Auto-Sizing?

#11 Post by Karol » 30.09.2014, 06:37

Tested with the release 665 http://www.freecommander.com/fc_beta_en.htm:
- open Tools - Settings
- select on the left "Column profiles"
- in the profiles list you have only one line "fc_default_view", select the line
- klick on "Define columns" button (hammer)
- in the new dialog select in the column list the "Name" column
- now deactivate the option "Autosize for 'Name' column"
- define "Width" value to e.g. 35
- klick on OK
- klick on OK

Rob Down Under
Posts: 2
Joined: 30.09.2014, 03:33

Re: Please? How Turn Off Column Auto-Sizing?

#12 Post by Rob Down Under » 30.09.2014, 08:51

Thank you Karol,
For taking the time to make that easy for me.

If I had tried to work that out myself, it would have taken a year (And I was an IT Analyst for 20 years)

If you (or family) are having any problems with PCs, I can remote in and probably fix them (no charge)
But I would not be surprised if you are better than I, at that as well.

Thanks again,
Rob
Australia

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests