Page 1 of 1

Shortcut text names

Posted: 18.03.2020, 23:04
by BGM
Say I create a shortcut to a program to put in the Start Menu folder.


The shortcut should look like this:

But FreeCommander always creates:

I can't find a setting to fix that. But even Windows Explorer doesn't do that.
IMHO, when you create a shortcut, you don't want the file extension in the shortcut's name.

Re: Shortcut text names

Posted: 18.03.2020, 23:26
by dsperber
I don't have that symptom. My *.LNK shortcuts appear in the corresponding Start Menu folders named exactly as I created them, whatever that is.

But then I also have UN-CHECKED the "hide extensions for known file types". So the complete name of anything always shows, including whatever .3 extension is present. And this is the case for .EXE programs as well, including .LNK shortcuts of objects.


So when creating the shortcut originally the ".exe" piece WOULD BE PRESENT, and in order to have it show up named as I want to see it (i.e. WITHOUT THE .EXE PIECE) I manually remove that extra .EXE suffix in my created shortcuts... just to keep their shortcut name "clean" and readable. So my shortcut on the desktop appears simply as SOMEPROGRAM, and the resulting Start Menu folder item is SOMEPROGRAM.LNK.

And that's also how things appear in what FCXE presents.

Re: Shortcut text names

Posted: 19.03.2020, 01:03
by BGM
In my Windows 10, I, too, have the setting unchecked.

Again, in Windows Explorer, when I create a shortcut, the .exe is not present in the shortcut name - it is created without that.
Only in FC does the .exe get appended to the shortcut name.

AH - it only does it if I drag-n-drop.

Try this: right-drag a file from one panel to the other and choose "create shortcut here".
Or left drag it to the other panel whilst holding alt.

Re: Shortcut text names

Posted: 19.03.2020, 04:39
by dsperber
Well, I don't know if drag-drop from one panel to another via mouse (as opposed to by using F5/F6 to accomplish copy/move for files) is supposed to be working in FCXE, but drag-drop using mouse doesn't seem to work me in 816.

I was trying to reproduce the actions and results you described, and opened my top panes to an arbitrary folder which contained an EXE, to be used for the drag/drop source. And I opened my bottom panes to an arbitrary folder to be used for the drag/drop target. I expected this to work normally (but differently depending on left-button or right-button drag). Note that I split my screen top/bottom, so there are two panes on top and two panes on bottom.


But when I left-click-and-hold-DRAG that BCOMPARE.EXE in the top-right pane to the bottom-right pane, nothing at all happens. Nothing. Similarly, nothing at all happens if I hold ALT down while also left-click-and-hold-DRAG from top-details pane to bottom-details pane. Nothing.

Note that I can do drag-drop with right-click or left-click from either top/bottom details pane (on the right) to the top/bottom Explorer Tree pane (on the left of that details pane) and the expected cursor-change and copy/move/prompt actions occur appropriately depending on left-click-drag or right-click-drag. But from the top-right (details) pane to the bottom-right (details) pane... nothing happens with left-click-drag, with ALT or not.

I normally use F5/F6 for my COPY/MOVE from source-details-pane to target-details-pane so I can't recall if this ever worked before, but nothing is happening now. I don't normally use FCXE to create "shortcuts" of EXE files, so I actually have nor experience with whether or not this ever worked before 816.

Now if I right-click-and-hold-DRAG from a source-details-pane to a target-details-pane, when I release the right button I get a FCXE popup, on which there is a "Context menu..." item.


And if I select that item I get the normal Windows Explorer context menu, on which "create shortcut" is an item.


If I then select that "create shortcut" item NOTHING HAPPENS. No shortcut is created in the target details folder. And even if I View -> Refresh, there is still no shortcut visible in that target folder. Obviously the shortcut of the EXE in the source folder WAS NEVER CREATED.

Something very very strange going on. Note that my source/target folders are on two different drive letters, so maybe that's part of it. I should try it on the same drive letter just to see if that makes any difference.

Now if I simply right-click on the EXE (BCOMPARE.EXE) in the source folder there is the Windows Explorer context menu which pops up, and "create shortcut" exists as an item.


If I select that item now IT DOES CREATE THE SHORTCUT in that same folder, with a name as expected (including the .EXE and with - SHORTCUT as a suffix).


So, either it was never supposed to work this way, or something is newly wrong. But I can't copy/move a file from source-details-pane to target-details-pane using mouse, either via left-click or right-click.

And I also cannot "create a shortcut" in any folder other than the source folder itself, using mouse.

All using 816.