windows 7 x64 I can not select multiple files

Bugs and issues.
Locked
Message
Author
vulkanita
Posts: 3
Joined: 05.03.2010, 00:30

windows 7 x64 I can not select multiple files

#1 Post by vulkanita » 17.12.2010, 20:04

when trying to select many items with the left mouse button on the list of files in windows 7 x64. I always selects the first and not selection by window appears for more than one item. :(

frozenfrog
Posts: 4
Joined: 04.08.2011, 20:55

Re: windows 7 x64 I can not select multiple files

#2 Post by frozenfrog » 14.12.2012, 00:11

I had prepared the following text for the same problem, I think. So this is a rephrasing of the above:

I'd like to respectfully point out a small but annoying feature/bug that started to affect Free Commander a few years ago. I will not stop using for fine product because of it, but I'm pretty sure I'm not alone in wishing it would go away.

In small icons mode, when your have multiple columns of files, there is no longer any way to select an arbitrary bloc of files by dragging the mouse pointer. That's because there is no longer a gap between adjacent columns where to anchor the mouse to start the selecting procedure. The mouse will select either the one file on the left or that on the right and think you want to move or copy this one file alone.

It used to be that you could use the gap between the end of the filename and the start of the next column on the right to anchor a drag selection, but no longer. For the purpose of selecting, this space is now considered a part of the filename on its left. To select a block, you have to use a combination of mouse and keyboard with both hands.

A small thing? Sure, but quality and polish are made of small things like that. :-)

But, as I said, I love Free Commander and I will continue to support it with or without a correction to this annoyance.
Thank you for yout fine product.

Karol
Posts: 623
Joined: 19.08.2007, 10:05

Re: windows 7 x64 I can not select multiple files

#3 Post by Karol » 14.12.2012, 13:59

No problem with FreeCommander XE.
You need only to deactivate the option "Full row select" under Settings - File/folder list.

frozenfrog
Posts: 4
Joined: 04.08.2011, 20:55

Re: windows 7 x64 I can not select multiple files

#4 Post by frozenfrog » 14.12.2012, 23:05

Oh! Then my problem is more serious.
This is one of the first things I tried when I first encountered the problem, a long time ago.
This setting doesn't seem to affect anything.
Any other possible culprit?

frozenfrog
Posts: 4
Joined: 04.08.2011, 20:55

Re: windows 7 x64 I can not select multiple files

#5 Post by frozenfrog » 15.12.2012, 00:14

Well, there is something more that can be said about the behavior of my mouse pointer.

I did a full clean reinstall (deleting settings everywhere, etc.)

Now, with Full Row Select either OFF or ON, when I repeatedly click in the white space after a filename and drag as if I wanted to select a bloc of filenames, the response is erratic, but never the one ecpected. Sometimes, the copy/move pointer tip will appear, and sometimes not (for the very same action, mind you). In either case, the dotted rectangle indicating the bloc selection area never appears, the pale blue rectangle supposed to indicate the files selected remains fixed on the initial filename at the end of which I tried to anchor the selection, and the even paler blue rectangle around the filename under the pointer follows it as if the mouse was not clicked and held.

I hope this detailed description helps. But if this behavior is not reproducible at your end, I realize I'm in a pretty dark place. So let me thank you right now, and no matter what, for your excellent response to my call. I just hope that, eventually, with some obscure update, it goes away. :-)

Thanks again.

Scott_Y
Posts: 503
Joined: 02.10.2009, 02:46
Location: Colorado, USA

Re: windows 7 x64 I can not select multiple files

#6 Post by Scott_Y » 12.01.2013, 17:13

frozenfrog wrote:... when I repeatedly click in the white space after a filename and drag as if I wanted to select a bloc of filenames, the response is erratic ...
It may be that you need to click ON the filename or very close to it. The empty space after a filename does not grab the file -- see, for example, an inability to drag an object when clicking on the adjacent empty space http://forum.freecommander.com/viewtopi ... 211#p14916.

Could you please test that and report back? Thanks.

Locked

Who is online

Users browsing this forum: No registered users and 2 guests