FTP, Linux

Discussion, questions and support.
Post Reply
Posts: 2
Joined: 11.04.2011, 15:47

FTP, Linux

#1 Post by krustybaguette » 12.04.2011, 12:23

I've seen on this board comment to the effect that File Commander won't run in Linux. True that there apparently is no native version of FC, but I have it running under WINE. My reason is that I am running a dual boot system (Win7 and LinuxMint 10 with a Netgear router (N600 WNDR3400) which has a usb port that is for connecting storage media. For some reason I cannot connect to the network drive through Netgear's ReadySHARE setup under Linux. It works as it should under Win7. I can connect to the drive using ftp either locally or over the internet under Linux. I can also log into the router and make configuration changes under either OS. However for day-to-day use external ftp is impractical at best.

That's how I cam to try out Free Commander (vs.2009.2b) hoping that I could use its internal ftp setup for more convenient transfer of files between the network drive and my Linux installation. I setup an ftp connection and get no listing of what's on the network drive, just "==== Connect: 4/12/2011 8:12:31 AM ====
11003 " in the ftp window. Under Extras/Settings/Drives I have combo box checked with "show free space" and show ftp as drive also checked.
Under FTP settings I am using the path suggested by my router, but am a little uncertain as to what I should enter under remote path. Local path would be my home directory (WINE c:\home\user)

Am I making some configuration error or is it possible that even though FC seems to be working under WINE perhaps the ftp part doesn't? TIA for any suggestions.


additional information:

I have now installed FreeCommander on my Win7 installation and trying to see if I can get the proper ftp settings under Windows and then transfer them to Linux. I got a different "error" message but still no startup folder on my network drive. to wit:
"==== Connect: 4/12/2011 10:01:59 PM ====
11004 The requested name is valid, but no data of the requested type was found."

What's meant by "data of the requested type" my "remote path"? which is /USB_STORAGE/kb
Those are the top directories on the network drive.
--krustybaguette tapping the keyboard in Olde Sturbridge Village--

Posts: 21
Joined: 04.09.2009, 11:48

Re: FTP, Linux

#2 Post by freecicero » 16.01.2016, 18:39

If you are still around, or anyone else knows, can someone indicate how they get past the "an error occurred in the application" window that pops up every time FC runs (in my case under Crossover)?

The bug report shows EAccessViolation but I can't make much more out of the report. If I click "Continue" then the program does continue to work, but on clicking on any drive or directory the same error window pops up over and over.

Has anyone gotten past this, as I would really like to use FC under Wine/Crossover


Posts: 708
Joined: 13.09.2012, 06:51

Re: FTP, Linux

#3 Post by Timon » 17.01.2016, 06:52

Free Commander (vs.2009.2b) is not supported any more.
If you need FTP function, it was implemented in new FC XE (even in latest public beta version).
So, first of all try FreeCommander XE 2016 Build 707 32-bit public beta release - http://freecommander.com/en/downloads/ and test it yourself under Wine/Crossover.

Posts: 21
Joined: 04.09.2009, 11:48

Re: FTP, Linux

#4 Post by freecicero » 17.01.2016, 23:28

OK thanks I was using a current donor version and still getting the error, so I suppose nothing has changed. Thanks!

Post Reply

Who is online

Users browsing this forum: No registered users and 12 guests