Page 1 of 1

VLC as default video player

Posted: 02.10.2009, 13:44
by freetools
Hi, thanks for FreeCommander.
I installed VLC which registered itself as default player for all possible video formats.
Using Windows XP, Windows Explorer starts VLC when opening an avi file. In FreeCommander, opening such a file or selecting it with right-click and "Play", nothing happens. I have to select "Play with VLC media player".
I later added *.avi and connected it with VLC in Preferences:Applications, but nothing changed.

Posted: 02.10.2009, 23:36
by matera
If it doesn't start when double-clicked, it's a Windows problem, not a FreeCommander issue. Right click an avi file for Properties and change the "opens with" there.

Posted: 07.11.2009, 15:59
by talkstosocks
try this:

right click on an avi file and select "Open With" then "Choose Program"

you will be prompted to select from a list. select vlc, and check the box "Always use the selected program to open this kind of file"

hit OK

this will make vlc the default for all of windows

Re: VLC as default video player

Posted: 27.05.2011, 21:41
by vlcvideo
Though this post is already old, I still want to give my own thought with regards to the matter. I Am presently using WMP..
There are two options.
1. Right click on the media file, and select Open With>Choose Program... Find VLC, and check "Always use the selected program to open this kind of file." Repeat for different extensions.
2. Open windows explorer. Go Tools> Folder Options. Cick the View File Types tab. Go through this and whenever you see a filetype you want to change, select it, and click Change next to Opens With:. Select VLC. Repeat for different extensions.
Thanks for sharing info!!

Re: VLC as default video player

Posted: 30.12.2017, 07:36
by Piercecrom
I'm used to playing videos with VLC player as it supports most video formats. It even allows user to play ISO on VLC.