Page 1 of 4

How replace WindowsExplorer for FreeCommander by defaut ?

Posted: 15.09.2008, 10:51
by Cyberdome
Hi,

How replace Windows Explorer for FreeCommander by defaut ?

When i click on a folder, it's open with windows explorer.


PS: Sorry for my bad english, i'm a bad student... and i'm french ;)

Posted: 15.09.2008, 13:04
by dcd_6
Cyberdome, I would love the same information.

1- I would like My Computer to default to FreeCommander
2- I would like Explorer to default to Free Commander
3- Any drive letter access from Run: also
4- File folders, etc.

Anyone have any thoughts?

Posted: 15.09.2008, 17:33
by ralfso
What's about forum-search for:

default AND file AND manager

???

Posted: 15.09.2008, 19:14
by Cyberdome
thx

i found it:

Open a new file in an editor and copy the following:

Code: Select all

REGEDIT4

[HKEY_CLASSES_ROOT\Folder\shell]
@="FreeCommander"

[HKEY_CLASSES_ROOT\Folder\shell\FreeCommander]
@="FreeCommander"

[HKEY_CLASSES_ROOT\Folder\shell\FreeCommander\command]
@="\"C:\\Programme\\FreeCommander\\FreeCommander.exe\" /C /R=\"%1\""
[/color]

Change the path in the last line to your fc-install-directory.
If you want the folder to be opened in the left pane, change /R to /L .

To change it back to default use this:

Code: Select all

REGEDIT4

[HKEY_CLASSES_ROOT\Folder\shell]
@=""

[-HKEY_CLASSES_ROOT\Folder\shell\FreeCommander]
[/color]
but it doesn't work completely on my pc. After execute script_above.reg i click on any folder and computer say "there is no application associated with this file type".

Posted: 19.10.2008, 17:39
by Emralegna
Salut Cyberdome,

As-tu bien modifier la ligne :

Code: Select all

@="\"C:\\Programme\\FreeCommander\\FreeCommander.exe\" /C /R=\"%1\""
pour qu'elle pointe vers ton dossier d'installation ?

Par défaut, ce devrait être :

Code: Select all

@="\"C:\\Program Files\\FreeCommander\\FreeCommander.exe\" /C /R=\"%1\""
Chez moi, j'ai séparé le dossier « Program Files » de la partition Windows pour l'installer sur D:\, donc j'ai modifier le C:\\Programme indiqué par D:\\Program Files et tout marche parfaitement. J'ai également changé le /R en /L car je préfère que le dossier fraichement ouvert soit sur le panneau de gauche.

En revanche je remarque qu'il n'y a pas de dossier Poste de Travail, mais tous les périphériques sont de toutes façons présent dans la barre des lecteurs, juste au dessus des onglets.

Voilà. :)

Posted: 19.10.2008, 18:24
by Cyberdome
Cette fois ça fonctionne merci. Pourtant j'avais bien modifié le chemin d'accès mais je crois que j'ai du faire un copié collé du chemin indiqué dans les propriétés de freecommander.exe , les antislashs étaient donc simple et j'ai du oublié de les doubler.

Posted: 19.10.2008, 21:23
by Dreamer
Please respect the forum rules:

• Post in English only.

You can use PM if you want to use another language. Thanks.

To clarify: How To Replace Explorer With FreeCommander

Posted: 31.12.2008, 23:13
by k3nt
To clarify:
How To Replace Explorer With FreeCommander

1. Open a text editor such as notepad (or my favorite "notepad++).

2. Paste the following text into a new document:
REGEDIT4

[HKEY_CLASSES_ROOT\Folder\shell]
@="FreeCommander"

[HKEY_CLASSES_ROOT\Folder\shell\FreeCommander]
@="FreeCommander"

[HKEY_CLASSES_ROOT\Folder\shell\FreeCommander\command]
@="\"C:\\Program Files\\FreeCommander\\FreeCommander.exe\" /C /R=\"%1\""
3. Save the document as "replace-with-freecommander.reg" (name the document as "replace-with-freecommander.reg")

4. Open the document named "replace-with-freecommander.reg" (double click it).

5. Click "Yes" to the following pop-up: "Are you sure you want to add the information in ..\replace-with-freecommander.reg to the registry?

Done. Enjoy!

Alternative solution

Posted: 02.01.2009, 10:16
by wkrekik
This .reg file didn't work for me. I don't no why but I have found another way :

1. In freecommander : Settings-->Shell menu-->Add FC to context menu : tick folders and drives
2. Control panel--> folders options --> file type--> Go to Drives or Files folders, click on advanced, then set Freecommander as default.

So if the straightforward .reg file solution doesn't work for some reason, you can try this alternative one

Re: To clarify: How To Replace Explorer With FreeCommander

Posted: 04.01.2009, 09:31
by jiZer
k3nt wrote:To clarify:
How To Replace Explorer With FreeCommander

1. Open a text editor such as notepad (or my favorite "notepad++).

2. Paste the following text into a new document:
REGEDIT4

[HKEY_CLASSES_ROOT\Folder\shell]
@="FreeCommander"

[HKEY_CLASSES_ROOT\Folder\shell\FreeCommander]
@="FreeCommander"

[HKEY_CLASSES_ROOT\Folder\shell\FreeCommander\command]
@=""C:\\Program Files\\FreeCommander\\FreeCommander.exe" /C /R="%1""
3. Save the document as "replace-with-freecommander.reg" (name the document as "replace-with-freecommander.reg")

4. Open the document named "replace-with-freecommander.reg" (double click it).

5. Click "Yes" to the following pop-up: "Are you sure you want to add the information in ..\replace-with-freecommander.reg to the registry?

Done. Enjoy!
It worked for me but i didnt like it that way so i wanted back like it was before so i deleted the reg key in the register. But now opens every map i doubleclick on in a new window it looks like this

Explore
Open

I want to get rid of the bold explore text like it was before.

Re: Alternative solution

Posted: 04.01.2009, 19:21
by settle
wkrekik wrote:This .reg file didn't work for me. I don't no why but I have found another way :

1. In freecommander : Settings-->Shell menu-->Add FC to context menu : tick folders and drives
2. Control panel--> folders options --> file type--> Go to Drives or Files folders, click on advanced, then set Freecommander as default.

So if the straightforward .reg file solution doesn't work for some reason, you can try this alternative one
Thank you, works perfect :)

When using IE

Posted: 12.01.2009, 03:51
by 2Clicks
Hi,

I've done both the options above and it works fine, EXCEPT when using Internet Explorer, say when attaching pictures to emails etc, Windows Explorer still opens for me to find the file/pic I want to attach.

Am I missing something?

Cheers

Posted: 12.01.2009, 11:19
by ralfso
I think, this can not be replaced because it is a open/save-Dialog which always use Explorer.exe.

back to default file manager

Posted: 01.03.2009, 05:02
by inkheart
Cyberdome wrote:thx

i found it:

Open a new file in an editor and copy the following:

Code: Select all

REGEDIT4

[HKEY_CLASSES_ROOT\Folder\shell]
@="FreeCommander"

[HKEY_CLASSES_ROOT\Folder\shell\FreeCommander]
@="FreeCommander"

[HKEY_CLASSES_ROOT\Folder\shell\FreeCommander\command]
@=""C:\\Programme\\FreeCommander\\FreeCommander.exe" /C /R="%1""
[/color]

Change the path in the last line to your fc-install-directory.
If you want the folder to be opened in the left pane, change /R to /L .

To change it back to default use this:

Code: Select all

REGEDIT4

[HKEY_CLASSES_ROOT\Folder\shell]
@=""

[-HKEY_CLASSES_ROOT\Folder\shell\FreeCommander]
[/color]
but it doesn't work completely on my pc. After execute script_above.reg i click on any folder and computer say "there is no application associated with this file type".
I used the code to make FC as the default and it worked. But since FC keeps on crashing, I wanted to go back to the default settings. I followed the code to go back to the default and it worked. Thanks.

Posted: 26.04.2009, 08:58
by Krys
Hey,

i used the clarification of k3nt to set up free commander the default explorer. But since that I can't open up the control panel anymore. It directs me to system32 in free commander.

I know within free commander is the control panel but clicking any entry has the same result.

any idea what went wrong? or how i can fix it to accesss my control panel entries again?

thx