Page 1 of 1

Search files with containing text in non English does not work

Posted: 23.09.2019, 11:01
by lourdas_v
I'm using the latest 64-bit donor version (Build 801) and the search functionality does not work correctly if I enter non English text in the Containing text field. If I enter text in English, it works.

Can someone confirm?

Re: Search files with containing text in non English does not work

Posted: 23.09.2019, 18:47
by Dreamer
Can't confirm, but we need some example to check.

Re: Search files with containing text in non English does not work

Posted: 25.09.2019, 12:01
by lourdas_v
I'm attaching 2 screenshots, where I search for a specific word in Greek and English respectively:

Image

Image

The test folder contains a text file with the following content:

Code: Select all

Γεια σου κόσμε!
Hello World!
The file is saved with UTF-8 encoding and Windows line ending (CRLF).

When searching the content in English, it succeeds, while searching for Greek it fails.

Re: Search files with containing text in non English does not work

Posted: 25.09.2019, 19:19
by Dreamer
Can't confirm, 801 donor 64-bit, Windows 10 1809 64-bit, used text from example.

Re: Search files with containing text in non English does not work

Posted: 25.09.2019, 19:21
by lourdas_v
Ok, is there somewhere an option that I'm missing that might get in the way of the search operation?

Re: Search files with containing text in non English does not work

Posted: 25.09.2019, 20:38
by Dreamer
I tested with default settings, try it too.

http://forum.freecommander.com/viewtopi ... a84d562589

Re: Search files with containing text in non English does not work

Posted: 26.09.2019, 04:49
by Timon
NOT confirmed, 801 donor (both 32 and 64-bit), Windows XP SP3 32-bit and Windows 7 64-bit.

Re: Search files with containing text in non English does not work

Posted: 26.09.2019, 04:56
by lourdas_v
Even with default settings, it still happens. The OS is Windows 10 64-bit, build 10.0.18362.295 (19.03).

Re: Search files with containing text in non English does not work

Posted: 26.09.2019, 05:15
by Karol
In the "Search files/folders" dialog you can select encoding for search text. Try to select UTF8.

Re: Search files with containing text in non English does not work

Posted: 26.09.2019, 05:18
by lourdas_v
Karol wrote:
26.09.2019, 05:15
In the "Search files/folders" dialog you can select encoding for search text. Try to select UTF8.
Yeap, that was it!

Thank you, sorry for the noise.

Re: Search files with containing text in non English does not work

Posted: 26.09.2019, 05:20
by lourdas_v
Is there a setting to permanently set the encoding option for the search files?

Re: Search files with containing text in non English does not work

Posted: 26.09.2019, 20:25
by Dreamer
Hm.. strange, it works good here, even with empty option.

You can save the profile and use option "Open first profile on start" (menu > Options).