Inconsistent presentation of quotation marks in parameters

Bugs and issues.
Post Reply
Message
Author
scott2907
Posts: 1
Joined: 17.04.2019, 13:53

Inconsistent presentation of quotation marks in parameters

#1 Post by scott2907 » 17.04.2019, 14:32

FreeCommander presents quotation marks in parameters if the path it represents contains a space.
But it does not if the path does not.

This makes sense, but in many use cases produces unexpected and undesired results.
For example when using FastCopy as a copy program, FastCopy requires a trailing slash "\" on the path name to operate correctly.

If you represent this as "%InactiveDir%\" then it WORKS if the path does not contain space:
("c:\mydir\mydir2\" is produced)

However it DOES NOT work if it does contain a space:
(""c:\my dir\my dir2"\" is produced)

If FC did not produce quotation marks in parameters in any circumstance, then the behaviour would be predictable and the user could enter the quotations wherever they needed them.
(To obtain backward compatibility with existing users is may be better to add new parameter names that NEVER include a quote? For example %InactiveDirNoQuote% - then "%InactiveDirNoQuote%\Remaining path" would work).

Thanks for a great free product. FC is a lifesaver !!!

viyi
Posts: 1
Joined: 17.04.2019, 11:08

Re: Inconsistent presentation of quotation marks in parameters

#2 Post by viyi » 17.04.2019, 17:04

just 7 minutes ago I found such an error where this message was written here "% InactiveDir%", if anyone knows how to solve thank you very much

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests