Page 1 of 1

starting trouble - can't start due to api-ms-win-crt-runtime-l1-1-0.dll

Posted: 05.01.2019, 17:32
by vsrawat
I am on w8.1-64-bit fc790 32 bit public

when I installed w8.1 afresh on a new hdd, and then installed fc, it installed, but on double clicking the icon to run, it gives the following message:

Image
The program can't start because api-ms-win-crt-runtime-l1-1-0.dll is missing from your computer. Try reinstalling the program to fix this problem.

though it says "can't start", yet it does start after giving the message 5 times.

I had been using fc on 8-32 bit for some 6 years and 8.1-64 bit for some 10 months, and installed it several times but no such problem occurred.

net search says that it could be due to non availability of "vc++ 2015 for visual studio". i installed that and 2017 also, but that didn't solve the problem.

however, I don't have that installed on W10-64 bit, and fc installed and is working well.

and ms word/ excel 2016 are also not starting throwing the same error.

All this related info to help you in finding the source of problem.

Thanks.

Re: starting trouble - can't start due to api-ms-win-crt-runtime-l1-1-0.dll

Posted: 05.01.2019, 18:08
by Marek
It is Windows problem.
All programs can be disturbing, eg. Adobe https://helpx.adobe.com/de/download-ins ... aunch.html
Solution proposed by Adobe: https://support.microsoft.com/en-gb/hel ... in-windows

Re: starting trouble - can't start due to api-ms-win-crt-runtime-l1-1-0.dll

Posted: 05.01.2019, 19:33
by vsrawat
of course it is windows problem.

I had downloaded Windows8.1-KB2999226-x64.msu
first it wouldn't install, then I searched net, and tried some methods and then it got installed, and all vc++ 2015 to 2017 got installed,

but the problem remains, in fc as well as in ms office itself.

so this direction of solution is not working.

You are not having this problem in you pc so I think you cannot try any solution. may be, if someone else is also having this sudden problem, he is welcome to report.

Could be that previously I was installing something before fc and before ms office, that was installing the required dll, but this time I had skipped that for some reason. I am thinking ever since, but couldn't find what it could be.

Thanks.

Re: starting trouble - can't start due to api-ms-win-crt-runtime-l1-1-0.dll

Posted: 05.01.2019, 20:01
by vsrawat
good news,

I uninstalled office 2016-64 bit, and installed office 2013-32 bit (that is what I had), and the problem is gone with word/ excell, as well as with fc.

seems that setup has installed the file that missing.

now that that file is there, some day I will try uninstalling 2013 and installing 2016-64 bit again to see whether that file is still there and problem doen't recur.

thanks.

Re: starting trouble - can't start due to api-ms-win-crt-runtime-l1-1-0.dll

Posted: 06.01.2019, 17:48
by vsrawat
One query.

Several program carry required vc++ in the installer, and install that along with software, so that vc++ problem is not there.

what vc++ versions are required for fc? Can there download location from MS site be given at the download page of fc?

or, even better, can they be clubbed in the fc installer or zip file itself, I don't know what permission is required from MS for that.

Thanks.

Re: starting trouble - can't start due to api-ms-win-crt-runtime-l1-1-0.dll

Posted: 06.01.2019, 18:45
by Marek
FreeCommander does not use vc++ at all.