Always use this app to open...

Bugs and issues.
Post Reply
Message
Author
ripsky4501
Posts: 7
Joined: 04.06.2015, 17:50

Always use this app to open...

#1 Post by ripsky4501 » 25.02.2016, 03:28

Hello,

I'm on Windows 10 using the 32 bit latest version (Build 715) of Free Commander. I've noticed that when I try to open a .jpg file in Free Commander, I always get the popup asking what program I want to use to open it. This continues even if I check "Always use this app to open .jpg files" box. But if I open the same file from Windows Explorer, I don't get any popup and the file opens right up in its default app, Irfanview. This has happened with every .jpg file I've tried opening.

This seems like a bug. Or do I need to toggle a setting or something?

Thanks.

dsperber
Posts: 94
Joined: 28.03.2010, 00:35

Re: Always use this app to open...

#2 Post by dsperber » 25.02.2016, 04:25

Tools -> Settings -> Programs -> Viewers tab

You can establish your default viewers/readers/players for FCXE.

Image

ripsky4501
Posts: 7
Joined: 04.06.2015, 17:50

Re: Always use this app to open...

#3 Post by ripsky4501 » 29.02.2016, 04:12

Thank you. That does work when I use the F3 hotkey to open the .jpg file but not when I double-click it or press enter while it's selected—that still gives me the "How do you want to open this file?" dialog. Is there any way to get it to work with double-clicking or pressing enter while it's selected? If not, it's no big deal because pressing F3 is not that bad. :)

Karol
Posts: 617
Joined: 19.08.2007, 10:05

Re: Always use this app to open...

#4 Post by Karol » 29.02.2016, 06:56

What about the reading of the help file?
http://www.freecommander.com/fchelpxe/e ... ction.html

ripsky4501
Posts: 7
Joined: 04.06.2015, 17:50

Re: Always use this app to open...

#5 Post by ripsky4501 » 29.02.2016, 19:28

Thanks for your help; that did the trick.

It is kind of strange that this seems to apply to only certain file extensions. For example, for .flac, .pdf, .pptx, .docx, and a host of others, I did not need to change any settings for them to open in FCXE as they do in Windows Explroer. But for at least .jpg and it seems for .rar as well, I do.

ektorbarajas
Posts: 3
Joined: 08.03.2016, 21:08

Re: Always use this app to open...

#6 Post by ektorbarajas » 22.06.2018, 18:57

Hi,

this seems to work when using the standard windows desktop application

But when using irfanview windows store app, even when defining the exact path for the program, it won't work, as soon as I double click on an image file I get an error message that access is denied

Is there a fix for this?

Thanks

davephx
Posts: 4
Joined: 26.03.2018, 00:36

Re: Always use this app to open...

#7 Post by davephx » 24.06.2018, 10:49

I set up the same and still have to take the extra step of "Always use this app to open .jpg files" box after setting up to always use InfanView in settings. Also, Win10 latest.

If i use F3 it opens in the assume its windows default viewer not InfanView.exe that I have FC set up pointed to.

UPDATE: Ok I didn't check the box in settings since was only the one for InfanView. Now F3 work correctly but if click from FC gives always use box even though I've clicked that for about 20 pictures and doesn't remember it just keeps asking.

ektorbarajas
Posts: 3
Joined: 08.03.2016, 21:08

Re: Always use this app to open...

#8 Post by ektorbarajas » 24.06.2018, 14:37

Yep, that is the problem

So I will need to use F3 until this is totally fixed

Regards

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests