Page 1 of 1

Extremely slow start-up

Posted: 29.06.2014, 16:11
by MikeG
I have FC XE 2014 Build 650.

I use tree view. (The left pane with the directory structure and the right pane wiht the files/directories in the directory which is selected on the left pane.)

I have 1 SSD, 2 HDDs, 1 Optical drive and 4 mapped network drives.

I have ticked the checkbox "Load network in background process on program start" in General settings.
Also I have ticked the radio button "Start with following folders" with the text boxes both set to C:\ in the Start program settings.

Start up is very slow; the last time I timed it and it took 82 seconds (by which time I had forgotten what I was going to do! :? )

Re: Extremely slow start-up

Posted: 30.06.2014, 10:49
by MikeG
I assume from the lack of suggestions that this is normal.

It's a shame but I'm going to have to abandon FC.

I've now set it up for networking as it says in the online help: FC doing the network loading, using cache for server list and loading the network in background.

It still takes 28 seconds to appear after clicking the icon! Windows explorer takes less than 1 second and Explorer++ takes about 1 second - neither are as good in other respects though.

It's a shame because once it's going it's the best file manager I've found.

Re: Extremely slow start-up

Posted: 30.06.2014, 15:36
by ralfso
Have you tried the portable version without any selfconfiguration?
So you can see if its normal on your system or not.

Maybe it can be the "size of folders" allways on.

Re: Extremely slow start-up

Posted: 30.06.2014, 21:06
by Dreamer
Alternative to hint from ralfso, it's also in "How to report a bug (Read before posting!)" topic...

"• Try to reproduce a bug with default settings and without the plugins. To do this use these command line parameters (your old settings file will be preserved):

/N /NewIni=FreeCommanderTest.ini /NoPlugins /Lng=English"

Re: Extremely slow start-up

Posted: 30.06.2014, 21:12
by zzzz123
MikeG wrote:I have FC XE 2014 Build 650.

I use tree view. (The left pane with the directory structure and the right pane wiht the files/directories in the directory which is selected on the left pane.)

I have 1 SSD, 2 HDDs, 1 Optical drive and 4 mapped network drives.

I have ticked the checkbox "Load network in background process on program start" in General settings.
Also I have ticked the radio button "Start with following folders" with the text boxes both set to C:\ in the Start program settings.

Start up is very slow; the last time I timed it and it took 82 seconds (by which time I had forgotten what I was going to do! :? )
I experienced the same problem on Windows XP with 5 mapped network drives. Startups took up to 90 seconds.

The issue was resolved with version 662. However, I advise you to hide network drives from drive bar using "Settings / Drives / Always exclude drives" option.

Re: Extremely slow start-up

Posted: 19.08.2014, 18:40
by darkstar
yeah, this bug is one of my favorites. I don't know your exact program settings and what you trying to achieve...
in my case I had my favorite tools bar pointing to a network folder, where XE tried to fetch the folder icon
from an mapped offline drive; because of that the start up took ages.
I fixed my issue by setting the folder to use a local icon e.g. from imageres.dll
Image
maybe this helps you too, if not best of luck.

Re: Extremely slow start-up

Posted: 19.10.2017, 14:54
by Lourens
I had a big archive on my desktop (windows) and after deleting the archive FreeCommander starts fast as ever before. With the archive it took more than 30 seconds to startup. This might be helpful as well.